Vulnerabilidade grave encontrada em biblioteca popular Java «Log4j»

Vulnerábilidade grave encontrada em biblioteca popular Java «Log4j»

Vulnerábilidade da biblioteca Log4j Java é um pesadelo empresarial: dado a facilidade de implementação e controle total obtidos, o impacto da falha é muito grave, afirma a empresa de segurança LunaSec. Muitos sistemas na web são vulneráveis, como a Steam, iCloud da Apple, Amazon, Cloudflare, Twitter e aplicativos como Minecraft. É altamente recomendável realizar a atualização para a versão “2.15.0-rc1”. As informações são do site Bleeping Computer.

Fonte: https://www.bleepingcomputer.com

php 7 elefante azul espaço óculos

phpinfo() e php -v mostram diferentes versões do PHP

O problema é esse meu phpinfo, exibe uma versão antiga :

phpinfo(); PHP version 5.6.10

E no terminal, exibe a versão que eu quero usar:

php -v PHP version 7.1

Abaixo, vou ensinar como corrigir versões diferentes do php no seu linux:

sudo a2dismod php5.6.10
sudo a2enmod php7.1
sudo systemctl restart apache2
service apache2 restart
apt-get install php-pear php7.1-dev php7.1-zip php7.1-curl php7.1-gd php7.1-mysql php7.1-mcrypt php7.1-xml libapache2-mod-php7.1
sudo apt-get update